Difference between revisions of "LaserCut 5.3"

From CoMakingSpace Wiki
Jump to navigation Jump to search
(merging in content from "Lasercut 5.3"; small adjustments)
(Added basic descriptions, images will follow)
Line 33: Line 33:
 
* The software must be installed in C:\LaserCut53 in order to work properly. There is a parameter in syscfg.ini which indicates the installation path. Changing it might get it to work from other locations as well but is untested. Try at your own risk.
 
* The software must be installed in C:\LaserCut53 in order to work properly. There is a parameter in syscfg.ini which indicates the installation path. Changing it might get it to work from other locations as well but is untested. Try at your own risk.
  
==Usage==
+
==Setup==
 +
===Setting the Worktable Size===
 +
The first thing to do after installation is to check for the correct worktable size. Our laser has a size of 90x60 cm. Please ensure your worktable is set up correctly.
 +
 
 +
If it is not, you can change it by navigating to File-->Machine Options (or pressing Ctrl+J).<br/>
 +
In the new window, please Navigate to "Worktable" and apply the following settings:
 +
 
 +
When clicking "Save", it will most likely ask you for a password. Just hit "OK".
 +
 
 +
==Basic Usage==
 +
 
 +
===Zoom to all objects===
 +
<pre style="color: red"> ADD IMAGE: Menubar with "zoom to all objects" tool highlighted </pre>
 +
Sometimes you need to ensure that all your objects are visible on the screen. To do so, please use "Zoom to all objects"
 +
 
 +
Note: You can use this tool in order to ensure all your objects are on the worktable. Objects outside the worktable will result in a soft stop of the laser.
 +
 
 +
===Zoom to table===
 +
<pre style="color: red"> ADD IMAGE: Menubar with "zoom to table" tool highlighted </pre>
 +
This tool is particulary helpful in case you zoomed in or out of your worktable and want to see the entire worktable centralized on your screen.
 +
 
 +
Sometime
 +
 
 +
==Preparing a Job==
 +
===Import your file===
 +
The first thing you need to do is to import your drawing. You can do so by navigating to File-->Import or by pressing Crtl+I. The following File formats are supported:
 +
* PLT
 +
* AI
 +
* DXF<br/>NOTE: When using Fusion, export the file. Do not just "save as".
 +
* DST
 +
* BMP
 +
* NC
 +
* JPG
 +
* GIF
 +
* PNG
 +
* TIF
 +
* TGA
 +
* PCX
 +
 
 +
===Preparing the Cut Paths===
 +
Once your file is imported, you will see the preview on the screen. The following tools might be handy when preparing your cut paths:
 +
 
 +
====Unite Lines====
 +
 
 +
In case you just start your job without any further tuning, you might recognize that the laser follows an odd order of steps to cut your paths.
 +
 
 +
In order to streamline this, please select the paths of your model and navigate to Tools-->Unite Lines.
 +
 
 +
Note: The default value of 0.100 as the unite tolerance is usually a pretty good value to recognize lines belonging together.
 +
 
 +
====Output order====
 +
You can control the order of the cuts by navigating to Tools-->Output Order
 +
 
 +
In the new window, you will get a list of output layers, which you can put into the desired order by selecting them on the left and moving them to the right side of the window.
 +
 
 +
==== Setting the entry point ====
 +
On each path you can select the entry point the laser will use by using the "Define cut route" tool. You can find this in the menu Laser-->Define cut route or in the menu bar:
 +
<pre style="color: red"> ADD IMAGE: Menubar with define cut route tool highlighted </pre>
 +
 
 +
Hint: If you press space when using this tool, a new window will open allowing you to edit some expert settings:
 +
<pre style="color: red"> ADD IMAGE: Lead In/Out Options </pre>
 +
 
 +
==== Copy ====
 +
 
 +
Especially when mass processing something, you might want to copy your drawing multiple times. LaserCut offers a few different options to do so:
 +
# Mark the paths, use CRTL-C and CTRL-V, then move the new paths
 +
# Mark the paths, navigate to Draw-->Copies <br/>This will create actual copies of your object in an array which you can define. After the copies have been created, they are independent of each other and can be modified and moved seperately.
 +
# Mark the paths, navigate to Laser-->Array output options <br/>This will allow you to laser your paths multiple times. Please note that the copies are not independent of each other and can only be moved together. Also, the same settings apply for all of them.
 +
 
 +
===Setting Power and Speed===
 +
You can set the power and speed for each layer seperately in the Control Panel:
 +
<pre style="color: red"> ADD IMAGE: Control Pane with highlighted layer section</pre>
 +
Here you can select the desired mode by using the correspondent drop done menu.
 +
 
 +
Double-clicking on a layer will open the speed settings for the specific layer:
 +
<pre style="color: red"> ADD IMAGE: Set Cut Options</pre>
 +
 
 +
Please put special focus on the "Corner Power". Usually you want to put this to the same power as your regular power.
 +
 
 +
==Controlling the Laser==
 +
<pre style="color: red"> ADD IMAGE: Control Panel</pre>
 
===Homing===
 
===Homing===
 +
In Order to Home the Laser, please press "Datum". (Fun Fact: "Datum" is not a strange translation, but actually the correct term (see [https://en.wiktionary.org/wiki/datum#Noun Wiktionary]).
 +
 +
Homing the Laser will cause it to move into the upper right corner. Please always home the laser before you use it.
 +
 +
NOTE: You can also Home the Laser by pressing "Datum" on the control panel of the Laser itself.
  
 
===Moving the Laser===
 
===Moving the Laser===
 +
You will need to move the Laser to it´s correct starting position, which you decided on when you prepared your job.
  
===Preparing the Cut Paths===
+
In order to do so, please use the X+/- and Y+/- Buttens in the Control Panel.
  
===Setting Power and Speed===
+
Please Note that you cannot control the Z-Height from within LaserCut. You will need to set the proper height on the machine itself!
  
 
===Uploading your Job===
 
===Uploading your Job===
 +
Once you are done with all preperation steps, you need to put your job on the machine. In order to do so, please press the "DownLoad" Button in the control panel. This will open a window called "Stand-alone file manager":
 +
<pre style="color: red"> ADD IMAGE: Stand alone file manager </pre>
 +
In here, you can select your desired job and press "Download file". You can also just hit "Download current" to put the latest job onto the machine.
 +
 +
If - for whatever reason - you want to store this exact setup and machine data, you can export the data by pressing "export file". This will allow you to save it as a .mol file.
  
 
===Starting and Stopping the Job===
 
===Starting and Stopping the Job===
 +
You can start the job in Lasercut or on the machine.
 +
 +
In order to start it from Lasercut, please use the "Start" Button on the control panel. You can also pause and stop the job by using the correspondent buttons.
  
 +
Please Note that it is recommended to always control the job from the laser itself!
  
 
[[Category:Laser Cutting]]
 
[[Category:Laser Cutting]]

Revision as of 22:23, 26 April 2020

SoftwareInfoBox

LaserCut 5.3 or Lasercut 5.3

LaserCut53 entry.jpg
Type: laser cutter driver/CAM
Platform: Windows (XP, 7, 8, 10 [1])
License:
Source:
Input Formats: PLT, AI, DXF, DST, BMP, NC, JPG, GIF, PNG, TIF, TGA, PCX
Output Formats: MOL
Users: Martin


Lasercut 5.3 is required to prepare a design file for our laser cutter. Its drawing functions are apparently quite terrible, so pretty much all users in forums etc. recommend to only use it for the very last steps!

If you are familiar with "our" previous laser cutter (the loaned Epilog Zing), this software will pretty much take over what you used to do with Visicut.

LaserCut 5.3 will be installed on a dedicated PC, which will be located next to the laser cutter itself.

This page needs more information as soon as we gather the necessary experience!

starting points:

Installation

We got a copy of LaserCut 5.3 from HPC Laser. You can get it from the orange USB drive located next to the laser cutter. However, the version we got does only work with the "soft dog" USB dongle, which will be attached permanently to the dedicated PC.

In order to prepare files on your own computer, you can install the software from another source. Most sources include an executable called "Lasercut53_Demo.exe" which can be used without the dongle but cannot operate the machine itself.

In case you plan to do these, please make sure that you replace your syscfg.ini with the one shipped with our laser (can be found on the mentioned USB drive).

Installation notes:

  • The software only works on Windows. Try Wine or other methods at your own risk, but be aware it's 32-bit software
  • The software must be installed in C:\LaserCut53 in order to work properly. There is a parameter in syscfg.ini which indicates the installation path. Changing it might get it to work from other locations as well but is untested. Try at your own risk.

Setup

Setting the Worktable Size

The first thing to do after installation is to check for the correct worktable size. Our laser has a size of 90x60 cm. Please ensure your worktable is set up correctly.

If it is not, you can change it by navigating to File-->Machine Options (or pressing Ctrl+J).
In the new window, please Navigate to "Worktable" and apply the following settings:

When clicking "Save", it will most likely ask you for a password. Just hit "OK".

Basic Usage

Zoom to all objects

 ADD IMAGE: Menubar with "zoom to all objects" tool highlighted 

Sometimes you need to ensure that all your objects are visible on the screen. To do so, please use "Zoom to all objects"

Note: You can use this tool in order to ensure all your objects are on the worktable. Objects outside the worktable will result in a soft stop of the laser.

Zoom to table

 ADD IMAGE: Menubar with "zoom to table" tool highlighted 

This tool is particulary helpful in case you zoomed in or out of your worktable and want to see the entire worktable centralized on your screen.

Sometime

Preparing a Job

Import your file

The first thing you need to do is to import your drawing. You can do so by navigating to File-->Import or by pressing Crtl+I. The following File formats are supported:

  • PLT
  • AI
  • DXF
    NOTE: When using Fusion, export the file. Do not just "save as".
  • DST
  • BMP
  • NC
  • JPG
  • GIF
  • PNG
  • TIF
  • TGA
  • PCX

Preparing the Cut Paths

Once your file is imported, you will see the preview on the screen. The following tools might be handy when preparing your cut paths:

Unite Lines

In case you just start your job without any further tuning, you might recognize that the laser follows an odd order of steps to cut your paths.

In order to streamline this, please select the paths of your model and navigate to Tools-->Unite Lines.

Note: The default value of 0.100 as the unite tolerance is usually a pretty good value to recognize lines belonging together.

Output order

You can control the order of the cuts by navigating to Tools-->Output Order

In the new window, you will get a list of output layers, which you can put into the desired order by selecting them on the left and moving them to the right side of the window.

Setting the entry point

On each path you can select the entry point the laser will use by using the "Define cut route" tool. You can find this in the menu Laser-->Define cut route or in the menu bar:

 ADD IMAGE: Menubar with define cut route tool highlighted 

Hint: If you press space when using this tool, a new window will open allowing you to edit some expert settings:

 ADD IMAGE: Lead In/Out Options 

Copy

Especially when mass processing something, you might want to copy your drawing multiple times. LaserCut offers a few different options to do so:

  1. Mark the paths, use CRTL-C and CTRL-V, then move the new paths
  2. Mark the paths, navigate to Draw-->Copies
    This will create actual copies of your object in an array which you can define. After the copies have been created, they are independent of each other and can be modified and moved seperately.
  3. Mark the paths, navigate to Laser-->Array output options
    This will allow you to laser your paths multiple times. Please note that the copies are not independent of each other and can only be moved together. Also, the same settings apply for all of them.

Setting Power and Speed

You can set the power and speed for each layer seperately in the Control Panel:

 ADD IMAGE: Control Pane with highlighted layer section

Here you can select the desired mode by using the correspondent drop done menu.

Double-clicking on a layer will open the speed settings for the specific layer:

 ADD IMAGE: Set Cut Options

Please put special focus on the "Corner Power". Usually you want to put this to the same power as your regular power.

Controlling the Laser

 ADD IMAGE: Control Panel

Homing

In Order to Home the Laser, please press "Datum". (Fun Fact: "Datum" is not a strange translation, but actually the correct term (see Wiktionary).

Homing the Laser will cause it to move into the upper right corner. Please always home the laser before you use it.

NOTE: You can also Home the Laser by pressing "Datum" on the control panel of the Laser itself.

Moving the Laser

You will need to move the Laser to it´s correct starting position, which you decided on when you prepared your job.

In order to do so, please use the X+/- and Y+/- Buttens in the Control Panel.

Please Note that you cannot control the Z-Height from within LaserCut. You will need to set the proper height on the machine itself!

Uploading your Job

Once you are done with all preperation steps, you need to put your job on the machine. In order to do so, please press the "DownLoad" Button in the control panel. This will open a window called "Stand-alone file manager":

 ADD IMAGE: Stand alone file manager 

In here, you can select your desired job and press "Download file". You can also just hit "Download current" to put the latest job onto the machine.

If - for whatever reason - you want to store this exact setup and machine data, you can export the data by pressing "export file". This will allow you to save it as a .mol file.

Starting and Stopping the Job

You can start the job in Lasercut or on the machine.

In order to start it from Lasercut, please use the "Start" Button on the control panel. You can also pause and stop the job by using the correspondent buttons.

Please Note that it is recommended to always control the job from the laser itself!